Air-Cockpit

Air-Cockpit

Echange et partage entre créateurs et réalisateurs de simulateurs de vol.
 
AccueilFAQGroupesS'enregistrerConnexion
Aircokpit est définitivement transféré à sa nouvelle adresse http://www.aircockpit.com. Ce forum sera bientôt en lecture seule. Voir messages d'annonce dans les sujets ci-dessous. L'équipe AIRCOCKPIT
anipassion.com
Partagez | 
 

 Premier essai infructeux

Aller en bas 
AuteurMessage
ganlhi

avatar

Nombre de messages : 72
Date d'inscription : 25/03/2009
Age : 34
Localisation : Toulouse

MessageSujet: Premier essai infructeux   Mar 7 Avr - 22:20

Messieurs, bonsoir !

Alors là je sèche... Je vous expose la situation :

- Cartes USB et Master reconnues et pas de souci dans le Controlador.
- Interrupteur actif dans le Controlador sur l'entrée 1 : coté branchement je suis bon
- ConfigIOCard : si j'envoie 1 sur l'offset $3102 (Master Batt switch) avec la fonction Write en bas à droite de la fenêtre, la batterie de l'avion s'allume : interface FSUIPC ok
- Par contre, quand j'essaie de faire ça avec mon interrupteur, ça ne fonctionne pas du tout ! Je précise que ma config est sauvée dans un fichier, et indiquée dans iocards.ini et ConfigIOCards.ini.

Voici ma config :

VARIABLES
NameAdress Length Function Initial value
BATTERY$3102 1


SW-NORMAL
NameN. InputVariableValue_ON/KeyValue_OFF/KeyType
SW_BATTERY1BATTERY1 0

Une idée du problème ?


Dernière édition par ganlhi le Mer 8 Avr - 19:56, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://ganlhi.net
ganlhi

avatar

Nombre de messages : 72
Date d'inscription : 25/03/2009
Age : 34
Localisation : Toulouse

MessageSujet: Re: Premier essai infructeux   Mer 8 Avr - 13:50

Personne n'a une petite idée ?

J'ai beau lire et relire le tuto de Claude, je ne vois pas ce qui peut être en cause. Toutes les parties du problème fonctionnent séparément, mais pas ensemble... Incompréhensible...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://ganlhi.net
Kelt760



Nombre de messages : 285
Date d'inscription : 15/03/2008
Localisation : Saclay

MessageSujet: Re: Premier essai infructeux   Mer 8 Avr - 13:56

Si tout marche séparément, c'est forcément un problème de câblage : ton inter ne met pas à 1 la bonne variable. Vérifie que tu est câblé sur la bonne pin (broche) de la master...

Sinon, je vois pas non plus.

Bon courage

_________________
www.simubaron.fr (attention adresse modifiée), le site des 2 Pierre. Venez nous voir !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.simubaron.new.fr
ganlhi

avatar

Nombre de messages : 72
Date d'inscription : 25/03/2009
Age : 34
Localisation : Toulouse

MessageSujet: Re: Premier essai infructeux   Mer 8 Avr - 14:02

Ben justement :
Citation :
Interrupteur actif dans le Controlador sur l'entrée 1 : coté branchement je suis bon

C'est bien la première chose que j'ai vérifié
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://ganlhi.net
Kelt760



Nombre de messages : 285
Date d'inscription : 15/03/2008
Localisation : Saclay

MessageSujet: Re: Premier essai infructeux   Mer 8 Avr - 14:20

Alors reste plus qu'une erreur dans ConfigIoCards.ini ou IOCards.ini, qui ne reconnaissent pas correctement la master. Je n'ai pas la doc sous les yeux, mais puisque ça marche dans Controlador, vérifie par rapport à controlador.ini.

Vérifie bien aussi avec USBCheck que la carte USB est reconnue (elle doit l'être si Controlador fonctionne, mais on ne sait jamais). USBCheck est sur le site OpenCockpit, ou sur notre site (voir signature).

Tu vas y arriver, y a pas de raison.

_________________
www.simubaron.fr (attention adresse modifiée), le site des 2 Pierre. Venez nous voir !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.simubaron.new.fr
ganlhi

avatar

Nombre de messages : 72
Date d'inscription : 25/03/2009
Age : 34
Localisation : Toulouse

MessageSujet: Re: Premier essai infructeux   Mer 8 Avr - 14:21

Ok, ce soir je compare controlador.ini et IOCards.ini ! J'vais l'avoir
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://ganlhi.net
stevelep

avatar

Nombre de messages : 512
Date d'inscription : 16/03/2008
Age : 44
Localisation : Neuchâtel LSGN, Suisse

MessageSujet: Re: Premier essai infructeux   Mer 8 Avr - 14:38

Salut,

Il n'y a plus beaucoup de personne qui utilise encore le programme IOcard.
Il est obsolète, son développement est stoppé depuis 4 ans et il ne
permet pas d'accèder à toutes les nouvelles cartes Opencockpits.
De plus ses fonctions sont très limitées.

Je te conseille fortement de commencer directement avec la programmation SIOC.
pour t'éviter de perdre du temps avec un soft que tu abandonneras tôt ou tard.
Le temps que tu vas perdre à configurer IOcard, te serait plus utile à mettre en
route le SIOC et à étudier les exemples de base et les fonctions simples.

BOB
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ganlhi

avatar

Nombre de messages : 72
Date d'inscription : 25/03/2009
Age : 34
Localisation : Toulouse

MessageSujet: Re: Premier essai infructeux   Mer 8 Avr - 14:40

J'ai bien l'intention d'utiliser SIOC, mais il s'agissait d'un test. Si ce que j'ai testé ne marche pas, je doute que ça fonctionne avec SIOC :)
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://ganlhi.net
stevelep

avatar

Nombre de messages : 512
Date d'inscription : 16/03/2008
Age : 44
Localisation : Neuchâtel LSGN, Suisse

MessageSujet: Re: Premier essai infructeux   Mer 8 Avr - 14:50

Avec l'interface SIOC et la console IOCP, il y a plus de moyens de test
pour trouver l'origine du problème. Il y a une fenêtre de device et plusieurs
indication de connection à FS, à IOCP et au SIOC.
Avec la console tu peux tester les entrées et les envois à FS via FSIUPC
en temps réel.

Comme la configuration d'IOCard et du SIOC sont parfois assez pointue (pour ne pas dire un peu complexe)
Tu vas perdre 2x ton temps.

Enfin je dit ça d'expérience, mais tu fait ce que tu veux ...

BOB
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ganlhi

avatar

Nombre de messages : 72
Date d'inscription : 25/03/2009
Age : 34
Localisation : Toulouse

MessageSujet: Re: Premier essai infructeux   Mer 8 Avr - 14:54

En effet, je n'avais pas pensé à ça... Je verrai tout ça ce soir alors.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://ganlhi.net
Kelt760



Nombre de messages : 285
Date d'inscription : 15/03/2008
Localisation : Saclay

MessageSujet: Re: Premier essai infructeux   Mer 8 Avr - 15:02

Complètement d'accord avec Bob. Passe directement à SIOC !

_________________
www.simubaron.fr (attention adresse modifiée), le site des 2 Pierre. Venez nous voir !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.simubaron.new.fr
ganlhi

avatar

Nombre de messages : 72
Date d'inscription : 25/03/2009
Age : 34
Localisation : Toulouse

MessageSujet: Re: Premier essai infructeux   Mer 8 Avr - 19:56

Bon... Pour l'avenir penser à lire correctement les fichiers .ini ! J'avais pas activé la carte USB dans celui de IOCards.

Accessoirement, pour vous rassurer, j'ai suivi vos conseils : mon montage doté d'un seul interrupteur fonctionne maintenant avec SIOC !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://ganlhi.net
Contenu sponsorisé




MessageSujet: Re: Premier essai infructeux   

Revenir en haut Aller en bas
 
Premier essai infructeux
Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Premier essai
» Premier essai HDR
» Capes médiévales - Premier essai couture
» mon premier essai en hdr
» Premier essai hdr

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Air-Cockpit :: Réalisations électronique :: Cartes d'interfaces-
Sauter vers: