Air-Cockpit

Air-Cockpit

Echange et partage entre créateurs et réalisateurs de simulateurs de vol.
 
AccueilFAQGroupesS'enregistrerConnexion
Aircokpit est définitivement transféré à sa nouvelle adresse http://www.aircockpit.com. Ce forum sera bientôt en lecture seule. Voir messages d'annonce dans les sujets ci-dessous. L'équipe AIRCOCKPIT

Partagez | 
 

 utilisation MCP Opencockpits (....je suis en détresse)

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
castabal



Nombre de messages : 21
Date d'inscription : 02/03/2009
Localisation : Lot et Garonne

MessageSujet: utilisation MCP Opencockpits (....je suis en détresse)   Dim 15 Mar - 15:59

Bonjour à tous,
je rame toujours dans l'utilisation du MCP B737 Opencockpits ! J'ai posé des questions, mais pas de réponses, donc, je vous recontacte.
J'ai acheté le MCP B737 Opencockpits, et la Multiradio. La multiradio marche très bien, par contre, j'ai suivi SCRUPULEUSEMENT les instructions données par le constructeur, en matière de sioc.ini en particulier, mais le MCP, que j'alimente par une alim extérieure, ne se connecte toujours pas !
Je suis donc à l'agonie....et très frustré de ne pas comprendre où cela coince.
J'utilise une Mastercard avec carte USBKeys, sous FS9 et Windows XP. La mastercard doit elle être en fonction pour utiliser le MCP, et déclarée dans le sioc.ini ?
Guimay, que j'ai contacté, utilise ce matériel sans aucun pb, mais il ne m'a pas répondu.
Aussi, si quelqu'un utilise ces deux matériels sans pb, peut il me faire parvenir ses deux fichiers (sioc.exe et sioc.ini) pour que j'arrive enfin à comprendre ce qui cloche.
Un grand merci d'avance

Pierre (castabal) castabal69@yahoo.fr
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
stevelep

avatar

Nombre de messages : 512
Date d'inscription : 16/03/2008
Age : 43
Localisation : Neuchâtel LSGN, Suisse

MessageSujet: Re: utilisation MCP Opencockpits (....je suis en détresse)   Lun 16 Mar - 0:30

As-tu essayé avec un HUB alimenté ?

Je crois me rappeller que pour utiliser une alim externe il y a un jumper à déplacer dans le MCP.
J'ai vendu mon MCP à Gilbert et je ne peux pas vérifier. Qui d'ailleur n'as pas
reçu d'email de ta part.
J'ai qq photo du MCP ouvert mais ce n'est pas assez net pour bien voir.

Soit tu as un HUB alimenté et tu essaies avec ca (sans l'alim evidemment)

Soit tu n'en as pas et tu ouvres le capot de ton MCP
Il y a un connecteur 2 pin en haut à gauche du circuit à l'endroit
ou arrivent les fils de l'alim et l'USB

Regarde à quoi c'est connecté ou envoie nous une photo en gros plan.

Merci

BOB

PS tu as déclaré ton MCP en (MASTER=0,5,1,0)
cela suppose que ton MCP est la seule carte détectée, si tu utilises une 2ème carte
(USB-Expension ou ModuleRadio) tu dois les déclarer avec des N° de device différent
on trouve le N° de device avec le programme USBCheck, on le note dans la commande
MASTER= à la dernière place

[ Number of device = 0 for Emulator or first USB card detected
[ For example, two USBExpansion cards connected with 3 and 2 Master cards used ]
[ MASTER=0,4,3,22 ]
[ MASTER=1,4,2,24 ]
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
castabal



Nombre de messages : 21
Date d'inscription : 02/03/2009
Localisation : Lot et Garonne

MessageSujet: utilisation MCP Opencockpits (....je suis en détresse)   Mar 17 Mar - 14:26

Bonjour Steve,
mon MCP n'était pas reconnu, car j'avais le fil blanc du cordon USB qui était déssoudé.
Je voudrais joindre quelques photos et fichiers pour illustrer mon pb, mais je ne vois pas de case "joindre un fichier" comme sur Yahoo !
Comment fait on sur le forum ?

Quand je lance sioc (voir sioc.ini) la fenêtre sioc s'ouvre, indiquant qu'il a chargé le fichier .ssi du MCP mais le MCP ne s'allume pas du tout, bien qu'il soit alimenté par l'alim extérieure. Le test avec MCPTest.exe montre toutefois que le MCP est en état de marche.
Tout se passe comme s'il ne recevait pas de données.

D'autre part, j'ai vérifié les circuits électroniques de l'alim extérieure; quand la fiche Jack de l'alim extérieure est enfoncée, elle alimente la plaque électronique, mais elle coupe l'alim fournie par la prise USB, ce qui me semble normal.

De plus, j'utilise la version 3.72 de FSUIPC non enregistrée. Dois je l'utiliser "enregistrée" pour que le MCP fonctionne ? Je n'ai pas eu cette info sur le site de OpenCockpits.

Dois je d'abord lancer FS2004 et l'avion PMDG avant de lancer le sioc ? ou cela n'a-t-il pas d'importance !
Je suis encore en détresse, mais j'ai progressé puisque mon MCP est maintenant reconnu par SIOC.
La multiRadio, par contre, marche au poil !

Merci de ta sollicitude, car sans tes conseils, je ne suis plus en détresse, je suis au fond du trou !

Pierre (castabal)
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
stevelep

avatar

Nombre de messages : 512
Date d'inscription : 16/03/2008
Age : 43
Localisation : Neuchâtel LSGN, Suisse

MessageSujet: Re: utilisation MCP Opencockpits (....je suis en détresse)   Mar 17 Mar - 15:38

Evidemment avec l'USB désoudé ca pouvait pas fonctionner ...
Bon vu que l'alim et le test fonctionnent et que le MCP est reconnu,
Il semble qu'il s'agisse maintenant d'un simple problème de config.

Lance le programme USB check avec MCP, multiradio et autres IOcards branchées
et donne nous les indications écrites dans la fenètre.
Je vais demander à Gilbert de faire la même chose pour comparer.

Pour les versions de FSUICP, je ne sais pas.

A suivre

BOB

http://www.opencockpits.com/modules.php?name=Downloads&d_op=getit&lid=254
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
castabal



Nombre de messages : 21
Date d'inscription : 02/03/2009
Localisation : Lot et Garonne

MessageSujet: Re: utilisation MCP Opencockpits (....je suis en détresse)   Mer 18 Mar - 9:28

Bonjour BOB,
selon ta demande, les éléments suivants:

test USBchecks:

IOCard USB V4.10 Device= 65
IOCard Radio V1.00 Device= 64
Logitech Attack 3 Device= 49
IOCard - MCP V1.00 Device= 69

Je joins une partie de mon fichier sioc.ini

IOCP_port=8092
IOCP_timeout=4000
Minimized=No
toggle_delay=20
CONFIG_FILE=.\sioc mcp PMDG.ssi
IOCard_disable=No

MASTER=0,5,1,69
MASTER=0,4,1,65

USBStepper=0,0
USBKeys=0,0
USBServos=0,0
USBRelays=0,0
USBDCmotor=0,0
USBAnalogic=0,0
FSUipcRefresh=100
IOCPclient0_disable=Yes
IOCPclient0_host=localhost
IOCPclient0_port=8090
IOCPclient1_disable=Yes
IOCPclient1_host=localhost
IOCPclient1_port=8099
Sound_disable=yes
Volume=100

Peux tu récupérer auprès de Gilbert son sioc.ini et sa fenêtre sioc.exe (après exécution) pour comparaison ?


Pour la photo du JUMPER sur la carte électronique, je ne peux te l'envoyer par la messagerie (sais pas faire). Par contre, je peux en fichier attaché si tu me donnes une adresse Email perso.

Merci beaucoup pour la suite

Castabal
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
stevelep

avatar

Nombre de messages : 512
Date d'inscription : 16/03/2008
Age : 43
Localisation : Neuchâtel LSGN, Suisse

MessageSujet: de   Mer 18 Mar - 12:28

Quelques remarques:

le problème vient probablement que tu utilises en même temps que le MCP et le Multiradio
une carte USB expansion. Il y a conflit entre le MCP et les IOCards.
C'est comme si tu utilises 2 USB expension en même temps, il faut donc
pouvoir les séparer dans le SIOC sinon le programme ne sais pas laquelle utiliser.

Gilbert, lui n'as pas d'autre carte branchée, il y donc utilisé le programme SIOC de base du MCP
sans rien modifier, avec un device 0 le SIOC prend la 1ère carte disponible et comme
Gilbert n'en a qu'une cela fonctionne.
Son fichier init ne te sera d'aucune utilité.

dans ton fichier ini tu déclare 2 cartes
MASTER=0,5,1,69
MASTER=0,4,1,65
seulement le premier chiffre est l'ID il est 2 fois "0", on ne peux pas donner
le même ID à 2 cartes sinon conflit ...

En résumé:

il ne faut pas mélanger tout les modules/carte sur le même SIOC.
Il te faut le programme pour le module multiradio avec une icone à lancer pour le démarrer

il te faut un SIOC pour MCP dans un dossier MCP avec une icone a cliquer pour lancer le MCP
et remplacer le dernier chiffre de MASTER= par le bon N° de device (69)
MASTER=0,5,1,69

Pour tes IOCards, il te faut un autre SIOC dans un autre dossier avec un autre ini
ou tu déclareras l'USB expansion avec le bon N° de device (65)

Je te conseille de recharger sur Opencockpits la version originale du SIOC MCP de base

Voila

BOB

PS: pour le jumper ca doit jouer comme ca
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
castabal



Nombre de messages : 21
Date d'inscription : 02/03/2009
Localisation : Lot et Garonne

MessageSujet: Re: utilisation MCP Opencockpits (....je suis en détresse)   Mer 18 Mar - 19:09

merci BOB pour la rapidité de ta réponse !
pataugeant un peu dans SIOC, et par rapport à ton conseil :
"C'est comme si tu utilises 2 USB expension en même temps, il faut donc
pouvoir les séparer dans le SIOC sinon le programme ne sais pas laquelle utiliser."

que veux tu dire par séparer le MCP et les IOCards dans le Sioc ? Faut il que dans C:\program files , j'ouvre un répertoire MCP indépendant du répertoire IOCards (c'est vrai que actuellement tout est mélangé dans le répertoire IOCards) ? et si c'est le cas, il faut alors que dans le nouveau répertoire MCP, je mette le fichier sioc du MCP, son fichier ini correspondant, le fichier .ssi du MCP et que je crée un raccourci de lancement sioc spécifique du MCP, comme je l'ai fait pour la multiradio !
Alors, comme pour la multiradio, j'aurai une icone de lancement spécifique au MCP .

Est ce que je m'approche de la vérité ? L'utilisation du SIOC, au départ, n'est pas très simple, et même plutôt hard pour moi, mais si l'on doit faire comme cela, j'y vois un peu plus clair, grace à toi.

Encore merci pour ta réponse!

castabal
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Guimay



Nombre de messages : 61
Date d'inscription : 15/03/2008
Age : 88
Localisation : Cruzy 34310 Hérault France

MessageSujet: MCP   Mer 18 Mar - 21:23

Bonsoir Pierre,

Tu sais, pour ma part, je n'ai fait qu'acheter un petit hub USB avec 4 connecteurs, pas d'alimentation, je n'ai rien changé, rien ajouté, j'ai seulement téléchargé les fichiers tels que je te l'ai dit, jj'ai les deux icones sur mon bureau........ et c'est tout.
Steve a raison, pas de carte, tout ira pour le mieux.
Amitiés.
Gilbert.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
stevelep

avatar

Nombre de messages : 512
Date d'inscription : 16/03/2008
Age : 43
Localisation : Neuchâtel LSGN, Suisse

MessageSujet: Re: utilisation MCP Opencockpits (....je suis en détresse)   Jeu 19 Mar - 2:09

Tu as compris,

tu auras un SIOC dans un dossier avec une icone pour le MCP

et un autre SIOC dans un autre dossier pour tes IOCards
les n° de device seront différent dans les 2 sioc.ini.

Tu auras donc 2 SIOC qui vont tourner en même temps

Dans l'absolu, on peut tout mettre sur le même mais c'est plus compliqué
car il faut utiliser des ID dans le code, tu pourras toujours le faire plus tard.

Bon, il est temps d'essayer:

Débranche les câbles USB de ta multiradio et ta carte USB-expansion.
Ne laisse que le MCP branché.

Télécharge le programme du MCP sur Opencockpit pour avoir l'original.

Essaye ensuite de le lancer sans rien modifier dans le .ini.

Si ca va pas, note le N° de device dans USBcheck et remplace le dernier 0
de la commande MASTER= dans l'ini et reessaye.

BOB
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
castabal



Nombre de messages : 21
Date d'inscription : 02/03/2009
Localisation : Lot et Garonne

MessageSujet: Re: utilisation MCP Opencockpits (....je suis en détresse)   Jeu 19 Mar - 10:44

Super BOB, pour ces nouvelles infos

je suis en partance pour 4 jours, mais je m'y mets dès lundi et je te tiens au courant, ainsi que Gilbert !

Un grand merci à tous les deux, (to même et Gilbert) je commence à "apercevoir la lumière..."
Le sioc, c'est pas très compliqué.......quand on a tout compris, surtout si on n'a pas de connaissances en systèmes informatiques !

A bientôt

Castabal
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
castabal



Nombre de messages : 21
Date d'inscription : 02/03/2009
Localisation : Lot et Garonne

MessageSujet: Re: utilisation MCP Opencockpits (....je suis en détresse)   Jeu 19 Mar - 12:03

Bob, avant de partir, et comme cela m'intrigue beaucoup, je suis passé à l' essai.
J'ai donc créé le dossier MCP indépendant, avec les fichiers adhoc, et tout marche très bien (ouf!!) avec le MCP: super ! avec
MASTER= 0,5,1,69 (le device donné par USBchecks
Quand je lance la multiradio, tout marche aussi !

Par contre, j'ai créé un fichier sioc pour gérer les feux de l'avion, le train, les flaps.... (j'ai fait attention qu'il n'y ait pas de conflit entre les N° d'entrées et sorties de la Mastercard) que j'ai appelé B737_elements.ssi et qui se trouve dans le répertoire IOCards, tout comme le fichier .ini de lancement
dans lequel j'ai affecté MASTER = 0,4,1,0 (ou MASTER = 0,4,1,65 N°device carte USB donné par USBChecks).
Dans les deux cas, si je lance le sioc du MCP, c'est bon, mais quand je veux lancer le sioc de l'USB (pour émuler mon fichier B737_elements.ssi) qui est dans IOCards, j'ai le message :
" could not bind socket. Adress and port are already in use "

Alors là, cela veut il dire que le sioc du MCP et celui de la mastercardUSB ne peuvent cohabiter, et qu'il y a conflit ?

Voilà, là je suis bloqué !

A bientôt

Castabal
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
castabal



Nombre de messages : 21
Date d'inscription : 02/03/2009
Localisation : Lot et Garonne

MessageSujet: Re: utilisation MCP Opencockpits (....je suis en détresse)   Jeu 26 Mar - 13:33

Bojour BOB,

je ne sais si tu as vu mon dernier message, dans lequel je bloque sur le message d'erreur “Could not bin
socket. Address and port are already in use”.
D'après la doc d'installation, "We have assigned the same port in two different sioc.ini and we intend
to run both simultaneously" et la solution " Open sioc.ini and change this number for other unused port
number"

Question: je suppose qu'il s'agit du port IOCP du sioc.ini mais comment savoir quel port n'est pas utilisé ?
D'autant que IOCPserver ouvre seulement le port 8090

J'ai affecté au sioc.ini lié à mon fichier sioc_elements.exe le port 8092 et ça marche pour les éléments, qui sont actifs.
J'ai affecté au deuxième sioc.ini lié à mon fichier sioc du mcp le port 8090 et quand je lance le sioc du mcp, j'ai de nouveau le message d'erreur !
Les deux siocs ne semblent pas vouloir travailler en parallèle....!

Aurais tu une solution ? ou m'orienter vers un collègue qui aurait rencontré ce problème ?

Un grand merci d'avance, car là je suis complètement bloqué !

Castabal
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
stevelep

avatar

Nombre de messages : 512
Date d'inscription : 16/03/2008
Age : 43
Localisation : Neuchâtel LSGN, Suisse

MessageSujet: Re: utilisation MCP Opencockpits (....je suis en détresse)   Jeu 26 Mar - 13:39

Salut,

Là, je n'ai pas de solution ...?

dans l'immédiat

Il faudrait voir dans le forum, si d'autre personnes utilise le MCP simultanément avec des IOCards ...
Regarde dans les répertoires de contructeurs de 737 et essaie de les contacter ...

peut-être Alain du Canada ?

BOB
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
castabal



Nombre de messages : 21
Date d'inscription : 02/03/2009
Localisation : Lot et Garonne

MessageSujet: Re: utilisation MCP Opencockpits (....je suis en détresse)   Jeu 26 Mar - 13:43

Merci BOB, je vais m'orienter comme cela, mais c'est qui BOB du canada ? quel indicatif ?
Si j'arrive à une solution, je te tiens au courant !

Castabal
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
stevelep

avatar

Nombre de messages : 512
Date d'inscription : 16/03/2008
Age : 43
Localisation : Neuchâtel LSGN, Suisse

MessageSujet: Re: utilisation MCP Opencockpits (....je suis en détresse)   Jeu 26 Mar - 13:45

Ah bein si,

J'ai trouvé une solution ...

En fait SIOC se connecte avec IOCP via un port, si tu ouvres 2 programmes SIOC il ne peuvent pas
partager le même port.

Donc j'ai crée 2 copies de SIOC sur mon PC et pour une j'ai changé le N° de port IOCP

[SIOC]
IOCP_port=8094


j'ai mis 94 au lieu de 92 (au hasard)

et c'est bon je peux lancer les 2 copies sans message d'erreur.

Voila

Good Luck

BOB
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
stevelep

avatar

Nombre de messages : 512
Date d'inscription : 16/03/2008
Age : 43
Localisation : Neuchâtel LSGN, Suisse

MessageSujet: Re: utilisation MCP Opencockpits (....je suis en détresse)   Jeu 26 Mar - 13:53

J'ai téléchargé le SIOC du MCP sur Opencockpits pour essayer

J'ai changé le port en 8094

J'ai lancé mon SIOC normal, ca marche sans problème chez moi

BOB
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
castabal



Nombre de messages : 21
Date d'inscription : 02/03/2009
Localisation : Lot et Garonne

MessageSujet: Re: utilisation MCP Opencockpits (....je suis en détresse)   Jeu 26 Mar - 14:01

FANTASTIQUE BOB, FANTASTIQUE ....tout marche !!

Encore merci et Re-merci !

J'ai affecté au sioc ini du fichier éléments le port 8092 et au sioc.ini du mcp le port 8094 comme tu me l'as dit...et CA MARCHE, y compris la multiRadio.

Par contre, je me suis amusé à affecter dans le sioc.ini elements le port 8090, et quand je lance ensuite le MCP (avec port 8094), j'ai de nouveau le message d'erreur !
Ainsi, en cas d'utilisation du MCP et de la IOCARD, il ne faut apparemment pas déclarer dans l'un des sioc.ini le port 8090, sinon, on bloque !
Pourquoi ? ça me dépasse largement, mais tant pis pour le "pourquoi" dès lors que cela marche...!

J'essaye le tout en vol et te tiens au courant ! Bravo BOB, même si le hasard, et encore merci de m'avoir aidé !

Castabal
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
castabal



Nombre de messages : 21
Date d'inscription : 02/03/2009
Localisation : Lot et Garonne

MessageSujet: Re: utilisation MCP Opencockpits (....je suis en détresse)   Jeu 26 Mar - 14:19

BOB, essai en vol concluant !

TOUT BAIGNE, peut être un hasard dans ton choix du 8094, mais un hasard qui fait bien les choses !
Bon vols et à bientôt

Castabal
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
stevelep

avatar

Nombre de messages : 512
Date d'inscription : 16/03/2008
Age : 43
Localisation : Neuchâtel LSGN, Suisse

MessageSujet: Re: utilisation MCP Opencockpits (....je suis en détresse)   Jeu 26 Mar - 14:23

le port 8090 est déjà utilisé par SIOC pour son client IOCP #1
il ne faut pas l'utiliser.

De rien

BOB


PS: note la solution quelque part, dans 2 ans si tu doit tout réinstaller dans un autre PC tu te
rappellera plus comment tu as résolu le problème ....
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
castabal



Nombre de messages : 21
Date d'inscription : 02/03/2009
Localisation : Lot et Garonne

MessageSujet: Re: utilisation MCP Opencockpits (....je suis en détresse)   Jeu 26 Mar - 16:17

Tout est noté, sur fichier et sur papier !

Bravo BOB !

A bientôt

Castabal
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: utilisation MCP Opencockpits (....je suis en détresse)   

Revenir en haut Aller en bas
 
utilisation MCP Opencockpits (....je suis en détresse)
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Utilisation de bonnettes macro
» Le craft robo pour une utilisation intense ?
» [JEU] Qui suis-je ? (identité de personnages du Whedonverse à deviner)
» [AIDE] Utilisation en modem avec Virgin Paradyse
» Je suis très laid

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Air-Cockpit :: Réalisations électronique :: Programmations Pics , Sioc et autres-
Sauter vers: